Apple changed the version of Java in High Sierra, moving some stuff around.

The solution is to install the "legacy" 1.6 version of Java and patch Memoir '44 Online with a fixed library.

Step 1: Installing the Legacy version of Java (1.6)

MacOS can run with several versions of Java installed at the same time, so it is safe to install.


Step 2: Patching Memoir '44 Online

We now need to change the libjogl_awt.jnilib libray inside the Memoir '44 Online app.

  • Download the fixed libjogl_awt.jnilib library on your Mac.
  • Right-click (or Control-click) on the Memoir '44 Online app to open the contextual menu and select "Show Package Contents". This opens a new window that contains the app's inside content (an app is actually a folder on the Mac).
  • Drill down to Contents > Resources > app > lib > macosx
  • Replace the libjogl_awt.jnilib file by the one you downloaded.
  • You can now close the window and start Memoir '44 Online.

Enjoy Memoir '44 Online!