Here are the minimum specifications/requirements needed for Ticket to Ride:

Apple
  • iOS: 8.0
  • MacOS: 10.11 64bit
Android
  • Google Play: 4.0.3
  • Amazon 5.0
Windows
  • Windows 7